JPress数据库安装报utf8mb4错误的解决办法

JPress之家发布 JPress建站 2016-10-26 388

不少jpress新手安装部署jpress的时候会发现报错,根据失色的观察,大部分都是报utf8mb4错误。

这篇简短的文章主要就是介绍下JPress数据库安装报utf8mb4错误的解决办法。

JPress首先明确一点的是mysql数据库版本最好在5.6或者5.6以上。

1、如果是mysql数据库版本问题,那么请安装新版数据库。

具体安装步骤可以参考《JPress环境安装之数据库Mysql环境安装

2、如果不是mysql数据库版本问题,那么请修改mysql编码格式,JPress不支持『utf8mb4』编码,请改成utf-8编码。

a、停止mysql服务。
b、修改mysql配置文件。
 
windows:安装路径下的:my.ini
linux:路径一般为:/etc/mysql/my.cnf